Requirements for Dabo

From Dabo Wiki
Jump to: navigation, search

Note

The installation instructions (InstallingDabo) for the platform of your choice satisfy the requirements below.

In order to work with Dabo, and to run apps built with Dabo, you will need the following:

Required

Python 2.6 through 2.7.x (2.5 may mostly work) (http://www.python.org/)

wxPython version 2.8 or later (http://www.wxpython.org/)

  • Note that the unicode version is required. The ansi version will not work. A good overview of installation of wxPython can be found at WxPyWiki:Getting_Started .

SQLite

Optional

Client libraries for your choice of database (If you want to use a database):

The steps to take a new Windows XP installation and get it up and running with Dabo are documented in Installation on Windows.

Or, if you are running Windows 2000 or later, you can install the Dabo Runtime Engine, which installs Dabo and all the supporting libraries on your machine in a single installer.

Platform-specific Instructions

Installation on Mac

Installation on Linux